Card image cap

QNAP Surveillance Station, HikVision & Push Notifications to vmobile app

Being a gadget freak I wanted my own home surveilllance security system. I already had the QNAP TS-451 ... so that was an easy choice for me. But wow, what a journey down the path with absolutely no real good documentation from QNAP SS.

I got help from there support team, but in the end they wanted to have access to my system since they could not replicate my issue. In the end, they did not even know there own system.

I got a HikVision DS-2CD2342WD which is amazing, no real complaints here, other than way to many options for motion detection, but thats luckily a good thing.

Here I will describe all the problems I ran into, so others may use less time setting it up. Kind of what needs to be done in that order.

QNAP

On the QNAP NAS box, make sure everything on myQNAPcloud is ok ... depending ofcause on how you want to access it from outside your own LAN ... I wanted to be able to access it on the "GO" so this was a nice easy way to see if everything is actually okay. I haven't published any services to the outside wrong. So I could probably close some of the ports since they both want 80, 443, 8080 and 8081 for everything to be "OK". But for a starter just to make sure this did not get in the way, I just opened all of them. I will however close all other than 443(https).

9304.png

This was also setup to support Push Notification on the QManager app for Android.

4012.png

For some odd reason, QNAP actually did a good job here ... option to remove devices, stop push and the best "Send test message". I ended up having something hanging from the ceeling to test motion detection on the Hik Vision camera ... 15 meter of rope to make something move in front of the camera :-). But this was way the easiest setup of it all ... the setup of push if something goes wrong to the NAS itself.

HikVision

The setup is done in Internet Explorer 11, because I could not get the plugin to work in other browsers for the Motion Detection.

Enable HikVison-CGI

This is needed for the QNAP SS to be able to correctly get information from the camera.

9774.png

  • Go to "Configuration" -> "Network" -> "Advanced Settings" -> "Integration Protocol"
  • Set a check in "Enable HikVision-CGI"
  • I also enabled ONVIF. HikVision has disabled this be default since firmware version 5.5.x
  • I also added a user "record", but this was only for testing other things.

Enable Basic Authentication

My tests shows these settings needs to be changed for motion detection to work. I'm not however 100% sure why, since it can connect and see the output from the camera without them. But no alarms on the SS.

3403.png

  • Click "Configutarion" > "System" > "Security"
  • Change both "RTSP Autentication" and "WEB Authentication" to "digest/basic" from "digest".
  • Click "Save".
  • You need to reboot the camera afterwards to make it take effect.

Setup Motion Detection

1523.png

  • Click the "Configuration" -> "Event", whcih will automatically take you to the "Basic Event" page.
  • Set a check in "Enable Motion Detection".
  • When trying to figure out what the Sensitivity needs to be ... if it's recording outside, it is a good idea to enable "Enable Dynamic Analysis for Motion", so if can see what is actually triggering a motion. Under "Configuration" on the page, there is also a "Export" mode which gives you lots of option. I did not really need that, but some people have complained about the Sensitivity of "20" is not low enough on "Normal" mode. The value jump in steps of "20".
  • Under the "Arming Schedule" i have 24/7.

3463.png

Under "Linkage Method" select "Notify Surveillance Center". I guess the "Trigger Recording -> A1" is if you have a network drive mapped and want the box to record to there. Not sure ... I havent enabled it.

Test Motion Detection is working on the Camera.

In the previous step, your can also check "Send Email" if you want to the Camera to send an email if there is any motion. Remember that Email/SMTP settings needs to be entered under "Network" I used this for testing that it actually worked ...

3302.png

You can also open this endpoint in a browser: http://x.x.x.x/ISAPI/Event/notification/alertStream

3838.png

It's used for server push to a client.

A guy here used it for Hikvision Motion Detection in OpenHAB using node.js, which is really awesome if you want to extend your surveillance system.

A link to hikvision-isapi_2.0-ipmd-service.pdf. If you want to play around.

Odd issues

Not sure if everybody runs into this, but if you don't get any motion alarms or can't get "Dynamic Analasis For Motion" to work, try "Disable" then "Save" and then "Enable" and "Save" again. I had this issue the first time I set it up. Just a thing to keep in mind.

2149.png

VMobile

Install the app on the mobile. Everything here should be pretty straight forward. Just remember to enable "Push Service".

4216.png

In the next step "QNAP SS" step there is more do do with the "Push Service" before is actually works.

QNAP SS

Now to the Surveillance Station, core whole setup.

Setting up the camera

3289.png

  • Go to "Camera Configuration", click "Add".
  • Uncheck "Search camera(s) automatically". ( I havent gotten this to work )

9260.png

Fill in the required information about the camera. Push the "Test".

3819.png

You should now see a screen shot of the Camera output. If you see a error like this:

5172.png

This is not necessary the IP address that is invalid, it can for some reason be a number of things. Hurray for QNAP. Here is a few I have seen.

  • Username/Password wrong.
  • HikVision-CGI not enabled.
  • The IP might actually be wrong.
  • Ports is wrong or not responding.

So this error is a VERY GENRIC error ... don't ever trust it ... ever.

Check the "Enable recording on this camera". Click "Next" until done ... just use default settings.

Setting up Alarm Settings

Go to "Event Management".

2632.png

Here you can see my settings.

I use "Traditional Mode". I'm not really sure what is default here ...

After done, click "Apply to all cameras" or the "Apply" in the bottom of the screen.

If you have verified that "Motion Detection" if working from the camera, we should not be able to see alarms.

6189.png

Go make some happy dance in front of the camera ... and go back to see the alarms. Hurray.

Setting up push service

In the Surveillance Station you should be able to see your phone whcih we installed in a previous step and that "Action" is On. Going back to the app and turning push service off will also turn off actions in this interface. And, ofcause also turn it off in the app if we turn it off here. This setting is synced.

7477.png

As you can see ... I'm logged in with "admin" on the phone. Next we need to make sure that the user is also allowed to get "Push Notications" for your camera. Whcih was something the QNAP team havent mentioned anywhere, not does there support team know it or just forgot about it.

7439.png

  • Click "Privilege Settings"
  • Edit the "admin" user, since we are logged in as "admin".
  • Normally all new camera won't have the "Push Service" checked. This needs to be done for every camera you add.

The "Push Service" page should really have a link to this ... or to what cameras the user has access to. This took me quite some time to find, since no pages I have read mentions this.

Conclusion

QNAP SS is in my world, not a production ready product. Way to much hidden information, no documentation, no debug options ... last update came in january 2017.

So ... if you are looking for a platform for your surveillance ... but aware of this. It works ... but OMG, there is just so much missing. But when finally setup ... it's fine. Hopefully I won't have to use more time on this.

9385.png

Got questions

If you have any question just comment below or contact me here.